MAC OS X Leopard и баг с PPPoE через tagged VLAN 802.1Q

20/06/2011

Достаточно, как казалось бы, обыкновенный сетап, подключение модемов через свитч с поддержкой 802.1Q, tagged VLAN создаваемый Mac OS X. Однако, PPPoE сессия через VLAN интерфейсы не поднимается (что вполне работает в Windows и Linux).

Но обо всем по порядку.

Есть модем от datagroup без PPPeE, статический IP, настроенный через tagged VLAN. И все работает, только вот медленно и канал довольно нестабильный.

Клиент подключается через Укртелеком, покупая ADSL модем. Подключение через PPPoE. Создаем новый tagged VLAN, настраиваем свитч, подключаем модем, настраиваем его в режим бриджа. И вот здесь начинается самое интересное.

PPPoE коннект попросту не проходит.

Сдуваем пыль с tcpdump и прослушиваем броадкасты:

tcpdump -n -e -i vlan2 ether host ff:ff:ff:ff:ff:ff

их нет!

tcpdump -n -e  ether host ff:ff:ff:ff:ff:ff

а теперь есть, но идут они через другой интерфейc.

Для того что бы выбрать интерфейс, с которого будут исходить PPPoE PADI пакеты необходимо создать PPPoE правым кликом на интерфейсе,

pppoe

Однако в нашем случае фокус в том, что при выборе интерфейсов vlan и клик на «создать службу PPPoE» ни к чему не приводят. При этом с физическими интерфейсами работает исключительно гладко.

Даже запуск вручную не приводит к позитивным результатам

pppd plugin PPPoE.ppp device vlan0 noauth defaultroute user username password pw

Описание бага на английском. Решения нет.

https://discussions.apple.com/thread/1706103?start=0&tstart=0

Теоретические выкладки про PPPoE

http://subnets.ru/blog/?p=308

P.S. пришлось настраивать модем в режим роутера и делать к серверу DMZ, что считаю решением не самым лучшим.

P.P.S. как workaround возможна настройка без VLAN на полностью физическом интерфейсе, а локальную сеть завернуть в tagged vlan. Однако данное решение сопряжено с другого рода сложностями.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *


*